EQ2 Forum Archive @ EQ2Wire

 

Go Back   EQ2 Forum Archive @ EQ2Wire > EverQuest II > Terrors of Thalumbra Beta > Zone and Quest Discussion
Members List Search Mark Forums Read

Notices

Reply
 
Thread Tools
Old 11-03-2015, 12:01 AM   #1
Marranda

New Member
Marranda's Avatar
 
Posts: n/a
Default

So on the sig quest, I need to talk to queen she has a icon lighting up and wont talk to me, lol the npc that was supposed to follow me is missing. Logged off for 2 hours come back and same thing. So I decide will work on another quest. Started Valley of the thralls the NPCs in city have the icon to use the clicky on them but u cant use it. Since I have already finished this quest on another toon, I went to the correct location blightstone barrens, the npcs there ( mostly do NOT have the icon) the ones that do, don't work. Adhalgar thrall at
/way 706.74,94.78,-699.44. no icon and clicking says he is not a enemy. All the ones in area say the same thing.
Also don't know if this has anything to do with Broken quest but Gninja was on a few hours ago an said they took broker down on beta to fix issues. Not sure how that can mess up quest givers and npcs. new ones seem to work but not these.
  Reply With Quote
Old 11-03-2015, 02:02 AM   #2
Kaitheel

Developer
Kaitheel's Avatar
 
Join Date: Jan 1970
Posts: 0
Default

Ah, ha! You'll be glad to know that I posted in the Thalumbra quest thread yesterday, "dhalgar citizens of outer Maldura will no longer appear as quest targets" after the next Beta update. Watch for that fix in the update notes. But as for the "not an enemy" message... I am not sure. Did that last longer than 60 sec?

~ Kaitheel
Kaitheel is offline   Reply With Quote
Old 11-03-2015, 04:12 PM   #3
Marranda

New Member
Marranda's Avatar
 
Posts: n/a
Default

ok I went to try this quest again today and still says Not an enemy on all the dhalgar in Blightstone barrens Frown sadly this stops progression of the quest on beta toon Zandie. Hope the fix is soon. and yes it last I can not use the item on any of the npcs in blightstone or the city courtyard area. Btw some have the icon and some do not. I also Deleted the quest and retook it thinking maybe it was me bugged, to no avail.
  Reply With Quote
Old 11-03-2015, 04:29 PM   #4
Taiyla

New Member
Taiyla's Avatar
 
Join Date: Jan 1970
Posts: 0
Default

I completed this quest last night. The trick is to go to the "Barren" area and look for the enthralled dhalgar that are aggro. They are found with other enthralled npc's that are aggro. The ones that show up non aggro don't work. If you can't find any aggro dwarves then kill the aggro enthralled left standing and they should repop.
Taiyla is offline   Reply With Quote
Old 11-03-2015, 04:45 PM   #5
Kaitheel

Developer
Kaitheel's Avatar
 
Join Date: Jan 1970
Posts: 0
Default

Ugh! Something is definitely broken if they are staying actors and not despawning. I'll be looking at this today!

~ Kaitheel
Kaitheel is offline   Reply With Quote
Reply

Thread Tools

Forum Jump


All times are GMT. The time now is 11:53 PM.

vBulletin skin by: CompleteGFX.com
Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All threads and posts originally from the EQ2 and Station forums operated by Sony Online Entertainment. Their use is by express written permission.